Velodyne HGS10 Amp Repair

This is what the inside of a Velodyne HGS10. If the amp is bad, you can send it to us for repair.  In some cases, you will not need to remove the woofer to access the amp.

, , , ,

23 Responses to Velodyne HGS10 Amp Repair

  1. Pete August 29, 2013 at 12:27 pm #

    Mine works, but seems like something isn’t right, such as today, I plugged it in and it made a nasty buzzing sound for about 5 minutes then the sound went away(like the amp had to warm up or something). What kind of prices are we talking for a rebuild of the amp and a re-coned woofer? (Approximately, I want to get an idea what i’m in for) or do I throw it away?

    thanx
    Pete

  2. jeff December 22, 2013 at 4:31 am #

    i have a VA-1012 in mint condition with minimal use, i turned it on the other day and its making strange cracking noise, the woofer and the passive radiator look fine without any cracks or tears so im going to assume that the amp is going or gone……..Id like to try and fix it what are the chances of the happening if i send it to you all for repair? Jeff

  3. cathy June 4, 2014 at 10:11 am #

    Most likely the problem is in the amp. You can send to us for repair.

  4. Andy September 3, 2014 at 10:50 am #

    I have an HGS10 which just started making a really loud constant frequency. It makes no difference if I unplug the receiver. Turning it off and does nothing? Any ideas?

    • Cathy Satin March 24, 2015 at 11:18 am #

      Send the amp to us and we will repair and update.

  5. LOUIS FOUGERE December 6, 2014 at 2:05 pm #

    I JUST BOUGHT A PRE OWNED VELODYNE HGS 10 SUBWOOFER.
    NORMAL SIGNAL SOUND BYPASS INPUT TO OUTPUT RCA. WOOFER DRIVER LOOKS PHYSICALLY PERFECT. NO SOUND EXCEPT FOR A LOUD NOISE POW, POW, POW COMES FROM WOOFER AS IF WOOFER IS BLOW.
    PLEASE TELL ME WHAT’S GOING ON?

    THANKS,

    LOUIS

    • Cathy Satin March 24, 2015 at 11:13 am #

      Most likely the problem is in the amp. Send to us and we will repair and update.

  6. Brandon March 24, 2015 at 11:00 am #

    I have Velodyne HGS 12BG that is doing the same type of thing. Is that something I can send to you for repair? Would I remove the amp and send it to you?

    • Cathy Satin March 24, 2015 at 11:04 am #

      Yes Yes Yes. Send the amp to us and we will repair and update.

  7. Fred August 18, 2015 at 11:47 am #

    I have a Velodyne HGS-12 that stopped working. I removed the speaker and poked around inside and found that the fuse was bad. I replaced the fuse, and reassembled – but it’s still silent. I did have one problem with reassembly, that I would also have if I sent you the amp: there’s an 8-pin connector (two rows of 4, I guess it pertains to the servo). I see where it plugs in, but it fits both ways. I also tried in both ways, and the unit doesn’t work either way. Did I damage it having it plugged in wrong? If I send you the amp for repair, can you tell me which way it goes when you return it? Plus…can you give me some idea of the cost? I don’t want to spend more than the sub is worth.

    • Cathy Satin August 18, 2015 at 1:55 pm #

      The cost is $400.00 to repair the amp. Comparable new subs at Velodyne are about $3800.00 each. When reinstalling, the 8 pin connector is on the bottom.

  8. Dan Cozza April 12, 2016 at 12:48 pm #

    do you have the servo for velodyne hgs10

  9. David Estabrook January 5, 2017 at 10:59 pm #

    Do you repair the drivers as well as the amp. I had my HGS10 amplifier replaced by velodyne and when i got it back i hear a 60hz hum whenever its on…. and now i notice playing the sub and moderate volumes i can hear a mechanical noise in the woofer. The woofer passes a visual inspection when removed, no loose spider or tinsel leads.

    Im at a loss.

    • Cathy Satin January 6, 2017 at 8:50 am #

      If you had your amp repaired or replaced at Velodyne, I suggest you contact them.
      You did not mention how long ago this was, but if it is within their warranty period, then contacting them is the best option because Velodyne no longer supports the HGS series. They do not have amps or parts and they no longer do repairs. We should be able to repair the amps at the component level except the spec sheets we received from Velodyne are incorrect. I have requested they make corrections and resend and we are waiting for this. The problems you describe with the woofer can be caused by the amp and a bad signal it is sending to the accelerometer. In any case, the woofers cannot be repaired.
      If you do not get satisfaction from Velodyne, then contact us again in a few weeks. I am hopeful we will have the specs we need to help with component level amp repairs.

  10. James Graham January 22, 2017 at 7:45 pm #

    Hi Cathy, I recently purchased a HGS-15 mark II from a dealer Winnipeg Manitoba. Now when I went to hook up the sub. I had 2 RCA connections hooked up to the sub from my sources. I turned on the main power switch, and there was a horrible howling sound from the woofer. At first I thought it was sound coming from my cable box. but there was no way that could happen because the cable is hooked up to my Marantz processor. The processor was not turned on. I unhooked all the cable except the power cable. Now I turned on the power switch and again I got the same sound. I took out the amp and hooked to another speaker. I got the same howling sound. So I know its not the driver it self. Can I get this amp repaired??

    • Cathy Satin January 23, 2017 at 8:25 am #

      At this time we are not working on the HGS amps. Velodyne provided us with schematics but they are incorrect. I am trying to get them to make the needed corrections. Until that time we are unable to provide service. Sorry.

  11. Peniamin January 30, 2017 at 4:04 pm #

    Hi Cathy, some years ago I purchased a HGS 12 in France. From the first time I heard back groung noise (harmonics of 50Hz). The French representative said it’s normal but after some weeks he tokk the decision to give me a new one and of course I got the same problem this bad 50Hz noise. I think that it’s inherent to the Analog Servo Drive system. Even you change the amplfier board you get the same problem. Did you find a solution regarding this issue ?
    Regards

    • Cathy Satin January 31, 2017 at 8:15 am #

      This amp would need to be repaired at the component level. At this time, we are unable to repair this model. Velodyne gave us incorrect specification sheets. We have requested corrections. If and when we get them, we will be able to repair this amp.

  12. Domingo Montoya February 12, 2017 at 8:46 pm #

    Hi.. I have a Velodyne Subwoofer DPS ll I know the amp its bad cause its not sound and doing wear noise.. you guys can get fix for me..Thx

    • Cathy Satin February 13, 2017 at 9:33 am #

      You can send for repair. Charges start at $150.00 and go up from there.

  13. Alan February 25, 2017 at 8:45 pm #

    I have a minivee 8 that started to make a loud humming sound. It starts when it receives a signal from the interconnect and stays until the unit is shut off. Is this likely issues with failing capacitors in the preamp section?

    • Cathy Satin February 27, 2017 at 11:24 am #

      It could be failing caps but normally it is more than that. We replace the entire amp. Contact us for order info.

Leave a Reply